Investigating Service Degradation
Incident Report for Discord
Resolved
Discord has been operating normally for more than an hour. All graphs are nominal and we understand what happened. The very brief synopsis is that we had table contention on the MongoDB instance that underlies a portion of our system. We do not believe this particular incident will recur in the near future.
Posted 4 months ago. Mar 17, 2018 - 15:49 PDT
Monitoring
The Redis server is back to normal. The team is again monitoring for any ongoing issues while performance returns to normal.
Posted 4 months ago. Mar 17, 2018 - 14:05 PDT
Identified
There is an ongoing issue with one of our Redis machines that powers certain operations that happen when messages are sent. We are working through the issue now.
Posted 4 months ago. Mar 17, 2018 - 13:50 PDT
Monitoring
We've addressed the underlying issue and services are recovering. Everybody should be able to reconnect and use Discord normally, but some operations may be a little slow as the system fully recovers. The team is keeping an eye on things.
Posted 4 months ago. Mar 17, 2018 - 13:12 PDT
Identified
We've identified that a MongoDB database is performing badly. We're taking steps to reduce load against the cluster now.
Posted 4 months ago. Mar 17, 2018 - 12:51 PDT
Investigating
We've become aware of an issue affecting connecting to Discord. We're looking into it now and will update as soon as we know more.
Posted 4 months ago. Mar 17, 2018 - 12:34 PDT