US-East - Disconnection Issues
Incident Report for Discord
Resolved
And we're back! Things look to have recovered. If you are still having issues, please reach out to us on twitter, @discordapp, or e-mail support@discordapp.com

We are looking into the root cause of why this happened and will update with a postmortem if we figure it out.
Posted Jun 28, 2016 - 20:22 PDT
Monitoring
Things appear to be coming back online now. We're monitoring the recovery.
Posted Jun 28, 2016 - 20:16 PDT
Identified
We've identified the issue as being a data-center wide outage on one of our US-East data centers. If you are unable to reconnect, try switching to US-Central, or US-South.

We're working on a resolution now.
Posted Jun 28, 2016 - 20:11 PDT
Investigating
We're looking into issues with users disconnecting on US-East region.
Posted Jun 28, 2016 - 20:08 PDT