Connection and Latency issues
Incident Report for Discord
Resolved
Discord is stable for a while now and all ancillary services have recovered. We don't anticipate a recurrence of this problem at this time (and if it does, we know how to recover it much more quickly now).

The root cause is still not entirely clear. We've seen seeing a lot of Google Cloud related migrations and TCP retransmits this morning, but the bulk of the issue today was caused when our primary MongoDB got into a bad state and was failing to serve traffic effectively. We had to perform some heavy load shedding to enable it to recover and get back to normal.
Posted Jul 12, 2018 - 14:27 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 12, 2018 - 14:25 PDT
Monitoring
The issues with our MongoDB have been addressed and we believe everything is returning to normal.
Posted Jul 12, 2018 - 13:35 PDT
Update
We're aware of more issues, and are investigating.
Posted Jul 12, 2018 - 13:00 PDT
Investigating
We're aware of more issues, and are investigating.
Posted Jul 12, 2018 - 13:00 PDT
Monitoring
Service is recovered, and our team is still investigating the causes of this issue.
Posted Jul 12, 2018 - 12:39 PDT
Investigating
We're aware of continued issues with the service and are investigating.
Posted Jul 12, 2018 - 12:15 PDT
Update
We are continuing to monitor for any further issues.
Posted Jul 12, 2018 - 11:26 PDT
Monitoring
We believe the blips to be caused by a network failure within google cloud platform. Our team is working to get more details, however, for now, the issue appears to have only been from 11:03 to 11:13 AM PDT.
Posted Jul 12, 2018 - 11:26 PDT
Investigating
We are investigating some connection and latency issues. The team is online and investigating, we will update when we know more.
Posted Jul 12, 2018 - 11:15 PDT
This incident affected: API.