Message Send Failures
Incident Report for Discord
Resolved
This incident has been resolved.
Posted 3 months ago. May 19, 2018 - 08:17 PDT
Investigating
We're investigating issues with messages failing to send or being delayed.
Posted 3 months ago. May 19, 2018 - 08:08 PDT