9/21 Trouble Connecting
Incident Report for Discord
Resolved
We've fixed the immediate issue and everybody should be able to reconnect to Discord as normal
Posted 3 months ago. Sep 21, 2018 - 11:59 PDT
Investigating
We've identified an issue affecting connecting to Discord right now. The team is online and working to fix the problem.
Posted 3 months ago. Sep 21, 2018 - 11:38 PDT