Slowness and failure sending messages

Incident Report for Discord

Resolved

Discord is completely back to normal.

The root cause was operator action. We were investigating some anomalous behavior on one of our systems (in our Guilds service) and we force-killed a process which unfortunately had a cascading impact. The system self-recovered like it was designed to, but that process took about 5 minutes for everything to settle down and return to normal.
Posted Jul 02, 2020 - 12:40 PDT

Monitoring

Service is coming back to normal, we are monitoring.
Posted Jul 02, 2020 - 12:26 PDT

Investigating

We are online and investigating issues with Discord, affecting normal usage and sending messages.
Posted Jul 02, 2020 - 12:20 PDT
This incident affected: API.