Attachment Image Previews
Incident Report for Discord
Resolved
The image resizing service has been successfully resurrected. Images that failed to load in the past should load again with a restart of the client.

The cluster got itself into a metastable failure-state due to a service discovery mechanism getting overloaded due to a new workload we've introduced onto the cluster in the past month. A deploy to fix a bug tripped it up. We've modified configurations to make this not happen, and will be taking appropriate measures over the next week to ensure that such an issue does not recur.

We apologize for any inconvenience this has caused!
Posted 15 days ago. Nov 01, 2018 - 20:59 PDT
Update
This issue will also affect icons throughout the application as we recover our image resizing service.
Posted 15 days ago. Nov 01, 2018 - 20:07 PDT
Identified
We are aware of issues with the attachment image previews not working - and are working on a fix currently.
Posted 15 days ago. Nov 01, 2018 - 20:00 PDT