Connection Loss / Failure to Reconnect
Incident Report for Discord
Resolved
Tonight's issue is over and Discord is working normally again. We're very sorry for the interruption this caused.

The root cause is under investigation. The team is actively working to understand the chain of events that led to this (and the last few) outages. We've got some good data on this crash and are putting together hypotheses that we can test in our staging & load test environments.

As mentioned in the last update, we do know the triggering event: a crash of one of our very large guilds that triggered a cascading failure in our sessions cluster. The crash is well understood and will not happen again, so we're confident we won't see a repeat of this cascading failure at this time.
Posted 7 months ago. Apr 19, 2018 - 00:29 PDT
Monitoring
The system has self-recovered and we are monitoring. We're doing some investigation now to understand what went wrong, but we know the proximal root cause and can say it will not recur this evening.
Posted 7 months ago. Apr 18, 2018 - 23:48 PDT
Investigating
We're investigating a major drop in connections and difficulties reestablishing connections. The team is online and looking at the problem now.
Posted 7 months ago. Apr 18, 2018 - 23:41 PDT