Large guilds intermittently unavailable.

Incident Report for Discord

Resolved

This incident has been resolved.
Posted May 03, 2021 - 20:15 PDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted May 03, 2021 - 19:59 PDT

Investigating

Guilds above 75,000 members are intermittently unavailable. We're investigating and will provide an update soon.
Posted May 03, 2021 - 19:36 PDT