Trouble Connecting
Incident Report for Discord
Resolved
We've fixed the immediate issue and everybody should be able to reconnect to Discord instantly and with no trouble.
Posted 10 months ago. Sep 21, 2018 - 09:32 PDT
Identified
We've identified an issue affecting connecting to Discord right now. The team is online and working to fix the problem.
Posted 10 months ago. Sep 21, 2018 - 08:31 PDT