Change in channel field causing bots to crash
Incident Report for Discord
Resolved
All servers should be operating as expected at this time.
Posted Apr 25, 2022 - 23:58 PDT
Update
Rollback continues, the majority of servers should be restored to nominal operation. Oncall Engineering expects to see full recovery within the hour.
Posted Apr 25, 2022 - 23:17 PDT
Update
The issue with admin users not receiving event dispatches in realtime in private channels without an explicit role should have been fully fixed.
We're still working on a fix that would solve the bot issue. You can still expect the affected bots to come back online in the next few hours.
Posted Apr 25, 2022 - 21:33 PDT
Identified
We've root caused the above issues, and are halfway reverting to a known good version. We expect affected bots to slowly come back online over the next few hours.
Posted Apr 25, 2022 - 21:06 PDT
Investigating
We discovered another issue with our latest release potentially impacting the dispatch of new messages and edits in realtime in private channels. We are working on a rollback and continue to investigate.
Posted Apr 25, 2022 - 20:04 PDT
Identified
We recently deployed a change to the channel payload that is incompatible with a couple popular bot libraries. As a result certain bots might be unavailable.

We have identified the issue and are working on a fix.
Posted Apr 25, 2022 - 19:31 PDT
This incident affected: API.